Openwrt wifi not working

Fix for Linksys EA3500 with OpenWRT 2.4GHz Wifi not working

In /etc/config/wireless , under the config wifi-device ‘radio0′ section, change the option hw_mode ’11a’ line to option hw_mode ’11g’ and restart. See the bottom of this post for an example.

Here is my thread on the OpenWRT forums.

I recently installed OpenWRT firmware on my Linksys EA3500 router so I could send WOL (Wake-on-LAN) packets to my PC to turn it on from outside of my local network. Everything worked great except for the 2.4GHz WiFi (radio0).

I looked through the system logs and found this:

# logread | grep radio0 . radio0 (2030): Hardware does not support configured mode radio0 (2030): wlan0: IEEE 802.11 Hardware does not support configured mode (2) (hw_mode in hostapd.conf) radio0 (2030): Could not select hw_mode and channel. (-2) . 

The referenced hostapd.conf is actually /var/run/hostapd-phy0.conf which is automatically generated from /etc/config/wireless . If we look in /etc/config/wireless we see this configuration for radio0:

# cat /etc/config/wireless config wifi-device 'radio0' option type 'mac80211' option path 'mbus/mbus:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0' option hwmode '11a' option channel 'auto' . 

«IEEE 802.11 Hardware does not support configured mode (2) (hw_mode»

This error tells us that the WiFi device’s wireless protocol ( hw_mode / hwmode ) has been improperly configured. As you can see from the configuration above, by default radio0 is incorrectly configured as a 5GHz radio with the 802.11a/n protocol ( 11a ). To fix this we need to change the value to 11g to correctly configure the radio to use the 802.11b/g/n 2.4GHz protocol.

Specifically, we need to change the option hw_mode ’11a’ line to option hw_mode ’11g’ in /etc/config/wireless like so:

config wifi-device 'radio0' option type 'mac80211' option path 'mbus/mbus:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0' option hwmode '11g' option channel 'auto' 

Restart the router to cause /var/run/hostapd-phy0.conf to be regenerated from your new /etc/config/wireless .

Mike Moore

Источник

Saved searches

Use saved searches to filter your results more quickly

You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session. You switched accounts on another tab or window. Reload to refresh your session.

Читайте также:  Mks wifi ps upload

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wi-Fi not working in OpenWRT Raspberrypi3 — wlan0 interface is not up #79

Wi-Fi not working in OpenWRT Raspberrypi3 — wlan0 interface is not up #79

Comments

Openwrt on RaspberryPi wifi not working — wlan0 interface is not up

conf/local.conf

MACHINE ??= «raspberrypi3»
INHERIT += » openwrt-distro-defaults »
DISTRO_FEATURES_append = » virtualization wifi»
MACHINE_EXTRA_RRECOMMENDS += «kernel-modules linux-firmware-bcm43430»
TCLIBC = «musl»
IMAGE_INSTALL_append = » initscripts hostapd linux-firmware-bcm43430 bridge-utils netifd bash openssh kernel-modules docker iptables wireless-tools dhcp-client crda iw linux-firmware-ralink linux-firmware-rtl8192ce linux-firmware-rtl8192cu linux-firmware-rtl8192su »
EXTRA_IMAGE_FEATURES ?= «debug-tweaks package-management»

conf/bblayers.conf

config wifi-device ‘radio0’
option type ‘mac80211’
option channel ’11’
option hwmode ’11g’
option path ‘/platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1’
option htmode ‘HT20’
option disabled ‘0’

config wifi-iface ‘default-radio0’
option device ‘radio0’
option network ‘lan’
option mode ‘ap’
option ssid ‘WifiName’
option encryption ‘none’

/etc/config/network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0’
option proto ‘static’
option type ‘bridge’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ’60’

config interface ‘wan’
option ifname ‘wlan0’
option proto ‘dhcp’

Kernel config fragments: kconfig.cfg

CONFIG_RTL8192CE=y
CONFIG_RTL8192C_COMMON=y
CONFIG_RTLWIFI=y
CONFIG_MAC80211=y
CONFIG_CFG80211=y

CONFIG_WIRELESS_EXT=y
CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_WEXT_SPY=y
CONFIG_WEXT_PRIV=y
CONFIG_CFG80211_WEXT=y
CONFIG_LIB80211=y
CONFIG_LIB80211_CRYPT_WEP=y
CONFIG_LIB80211_CRYPT_CCMP=y
CONFIG_LIB80211_CRYPT_TKIP=y
CONFIG_HOSTAP=y

CONFIG_BRCMUTIL=y
CONFIG_BRCMFMAC=y
CONFIG_BRCMFMAC_PROTO_BCDC=y
CONFIG_BRCMFMAC_SDIO=y
CONFIG_BRCMFMAC_USB=y
CONFIG_BRCMFMAC_PROTO_MSGBUF=y
CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y

I am not seeing any errors in «dmesg» or «logread», but the wifi is not working on OpenWRT.
@kraj Could you please let me know, what are all the configurations required to bring up the wifi on OpenWRT.

The text was updated successfully, but these errors were encountered:

if you use latest master meta-raspberrypi layer it uses right firmware blobs to bringup on-board wifi
I have not tried to bring up wifi on pi3 myself with openwrt layer but it works fine with OE in general

Читайте также:  Чтобы вай фай всегда работал

@cshoredaniel ,
I am replying on behalf of Satish Naidu, we work together.
We are including netifd and using it.
when we try apply the wifi config and try bringing up wlan0 is shown up in ifconfig -a but wlan0 link is not ready. Please suggest how to get it work on yocto with openwrt layer.
Below is our configuration to bring up wifi on opewrt platform.
In file /etc/config/wireless:
config wifi-iface
option ssid ‘linksys’ # the wifi name its connecting too
option device ‘radio0’ # the radio we are using to connect
option mode ‘sta’ # client mode
option key ‘password’ # wifi password
option encryption ‘psk2+ccmp’ # encryption level
option network ‘wwan’ # interface name (used for dhcp and firewall zone etc)
option bssid ‘xx:xx:xx:xx:xx:xx’
In file /etc/config/network
config interface ‘wwan’
option proto ‘dhcp’
In file /etc/config/firewall
config zone
option name ‘wan’
option input ‘REJECT’
option output ‘ACCEPT’
option forward ‘REJECT’
option masq ‘1’
option mtu_fix ‘1’
option network ‘wan wwan’

#/etc/init.d/firewall restart # restarts firewall
#/etc/init.d/network restart # restarts network
#wifi #restarts wifi**

lsmod on the yocto build:
root@LEDE:/# lsmod
brcmfmac 307200 0
brcmutil 16384 1 brcmfmac
bridge 122880 0
cfg80211 573440 1 brcmfmac
evdev 24576 0
fixed 16384 0
ip_tables 24576 3 iptable_nat,iptable_mangle,iptable_filter
ip6_tables 24576 2 ip6table_mangle,ip6table_filter
ip6table_filter 16384 0
ip6table_mangle 16384 0
ipt_MASQUERADE 16384 1
ipt_REJECT 16384 2
iptable_filter 16384 1
iptable_mangle 16384 0
iptable_nat 16384 1
ipv6 438272 37 nf_conntrack_ipv6,nf_defrag_ipv6,nf_nat_masquerade_ipv6,ip6table_mangle,bridge,[permanent]
llc 16384 2 bridge,stp
nf_conntrack 126976 14 nf_nat_ipv4,nf_conntrack_netlink,nf_conntrack_ipv4,ipt_MASQUERADE,xt_state,xt_nat,xt_conntrack,xt_REDIRECT,xt_NETMAP,xt_CT,nf_nat_masquerade_ipv4,nf_conntrack_ipv6,nf_nat_masquerade_ipv6,nf_nat
nf_conntrack_ipv4 16384 10
nf_conntrack_ipv6 16384 0
nf_conntrack_netlink 36864 0
nf_defrag_ipv4 16384 1 nf_conntrack_ipv4
nf_defrag_ipv6 24576 1 nf_conntrack_ipv6
nf_log_common 16384 1 nf_log_ipv4
nf_log_ipv4 16384 0
nf_nat 28672 6 nf_nat_ipv4,xt_nat,xt_NETMAP,nf_nat_redirect,nf_nat_masquerade_ipv4,nf_nat_masquerade_ipv6
nf_nat_ipv4 16384 1 iptable_nat
nf_nat_masquerade_ipv4 16384 1 ipt_MASQUERADE
nf_nat_masquerade_ipv6 16384 0
nf_nat_redirect 16384 1 xt_REDIRECT
nf_reject_ipv4 16384 1 ipt_REJECT
nfnetlink 16384 1 nf_conntrack_netlink
rfkill 32768 1 cfg80211
stp 16384 1 bridge
uio 20480 1 uio_pdrv_genirq
uio_pdrv_genirq 16384 0
x_tables 32768 23 ipt_MASQUERADE,xt_time,xt_tcpudp,xt_tcpmss,xt_state,xt_nat,xt_multiport,xt_mark,xt_mac,xt_limit,xt_conntrack,xt_comment,xt_REDIRECT,xt_NETMAP,xt_LOG,xt_CT,iptable_mangle,iptable_filter,ip_tables,ipt_REJECT,ip6table_mangle,ip6table_filter,ip6_tables
xt_CT 16384 0
xt_LOG 16384 0
xt_NETMAP 16384 0
xt_REDIRECT 16384 0
xt_comment 16384 50
xt_conntrack 16384 8
xt_limit 16384 1
xt_mac 16384 0
xt_mark 16384 0
xt_multiport 16384 0
xt_nat 16384 0
xt_state 16384 0
xt_tcpmss 16384 0
xt_tcpudp 16384 4
xt_time 16384

On 2018-05-09 08:29 AM, sandeepyedire wrote: @cshoredaniel We are including netifd and using it. when we try apply the wifi config and try bringing up wlan0 is shown up in ifconfig -a but wlan0 link is not ready. Please suggest how to get it work on yocto with openwrt layer. Below is our configuration to bring up wifi on opewrt platform. In file /etc/config/wireless: config wifi-iface option ssid ‘linksys’ # the wifi name its connecting too option device ‘radio0’ # the radio we are using to connect option mode ‘sta’ # client mode

Читайте также:  Длинк дир 300 настройка wifi

Ah, I though you were doing AP mode. Do you have wpa_supplicant? (I’m not sure if that’s enough or if a recipe doing OpenWRT-like multi-call wapd is necessary for client mode). Does the client attempt to make a connection but fail (i.e. when you watch wireless traffic)? Do you have busybox’s udhcpcd included? (netifd doesn’t grok dhcp-client from ISC). Regards, Daniel

option key ‘password’ # wifi password option encryption ‘psk2+ccmp’ # encryption level option network ‘wwan’ # interface name (used for dhcp and firewall zone etc) option bssid ‘xx:xx:xx:xx:xx:xx’ In file /etc/config/network config interface ‘wwan’ option proto ‘dhcp’ In file /etc/config/firewall config zone option name ‘wan’ option input ‘REJECT’ option output ‘ACCEPT’ option forward ‘REJECT’ option masq ‘1’ option mtu_fix ‘1’ option network ‘wan wwan’ #/etc/init.d/firewall restart # restarts firewall #/etc/init.d/network restart # restarts network #wifi #restarts wifi** *lsmod on the yocto build:* ***@***.***:/# lsmod brcmfmac 307200 0 brcmutil 16384 1 brcmfmac bridge 122880 0 cfg80211 573440 1 brcmfmac evdev 24576 0 fixed 16384 0 ip_tables 24576 3 iptable_nat,iptable_mangle,iptable_filter ip6_tables 24576 2 ip6table_mangle,ip6table_filter ip6table_filter 16384 0 ip6table_mangle 16384 0 ipt_MASQUERADE 16384 1 ipt_REJECT 16384 2 iptable_filter 16384 1 iptable_mangle 16384 0 iptable_nat 16384 1 ipv6 438272 37 nf_conntrack_ipv6,nf_defrag_ipv6,nf_nat_masquerade_ipv6,ip6table_mangle,bridge,[permanent] llc 16384 2 bridge,stp nf_conntrack 126976 14 nf_nat_ipv4,nf_conntrack_netlink,nf_conntrack_ipv4,ipt_MASQUERADE,xt_state,xt_nat,xt_conntrack,xt_REDIRECT,xt_NETMAP,xt_CT,nf_nat_masquerade_ipv4,nf_conntrack_ipv6,nf_nat_masquerade_ipv6,nf_nat nf_conntrack_ipv4 16384 10 nf_conntrack_ipv6 16384 0 nf_conntrack_netlink 36864 0 nf_defrag_ipv4 16384 1 nf_conntrack_ipv4 nf_defrag_ipv6 24576 1 nf_conntrack_ipv6 nf_log_common 16384 1 nf_log_ipv4 nf_log_ipv4 16384 0 nf_nat 28672 6 nf_nat_ipv4,xt_nat,xt_NETMAP,nf_nat_redirect,nf_nat_masquerade_ipv4,nf_nat_masquerade_ipv6 nf_nat_ipv4 16384 1 iptable_nat nf_nat_masquerade_ipv4 16384 1 ipt_MASQUERADE nf_nat_masquerade_ipv6 16384 0 nf_nat_redirect 16384 1 xt_REDIRECT nf_reject_ipv4 16384 1 ipt_REJECT nfnetlink 16384 1 nf_conntrack_netlink rfkill 32768 1 cfg80211 stp 16384 1 bridge uio 20480 1 uio_pdrv_genirq uio_pdrv_genirq 16384 0 x_tables 32768 23 ipt_MASQUERADE,xt_time,xt_tcpudp,xt_tcpmss,xt_state,xt_nat,xt_multiport,xt_mark,xt_mac,xt_limit,xt_conntrack,xt_comment,xt_REDIRECT,xt_NETMAP,xt_LOG,xt_CT,iptable_mangle,iptable_filter,ip_tables,ipt_REJECT,ip6table_mangle,ip6table_filter,ip6_tables xt_CT 16384 0 xt_LOG 16384 0 xt_NETMAP 16384 0 xt_REDIRECT 16384 0 xt_comment 16384 50 xt_conntrack 16384 8 xt_limit 16384 1 xt_mac 16384 0 xt_mark 16384 0 xt_multiport 16384 0 xt_nat 16384 0 xt_state 16384 0 xt_tcpmss 16384 0 xt_tcpudp 16384 4 xt_time 16384 — You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub , or mute the thread .

Источник

Оцените статью
Adblock
detector