- Saved searches
- Use saved searches to filter your results more quickly
- License
- phalloc/phalloc-sniffer
- Name already in use
- Sign In Required
- Launching GitHub Desktop
- Launching GitHub Desktop
- Launching Xcode
- Launching Visual Studio Code
- Latest commit
- Git stats
- Files
- README.md
- About
- Сбор MAC-адресов мобильных устройств в маркетинговых целях
- Как это работает?
- Техническая реализация
- Примеры использования
- Результаты тестирования и выводы
- Решения
- Как сканировать MAC адреса проходящих мимо юзеров по WiFi
- yuracheh
- f22
Saved searches
Use saved searches to filter your results more quickly
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session. You switched accounts on another tab or window. Reload to refresh your session.
MAC Address sniffer. Captures packets on the WiFi network and outputs the MAC address and RSSI to STDOUT.
License
phalloc/phalloc-sniffer
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Name already in use
A tag already exists with the provided branch name. Many Git commands accept both tag and branch names, so creating this branch may cause unexpected behavior. Are you sure you want to create this branch?
Sign In Required
Please sign in to use Codespaces.
Launching GitHub Desktop
If nothing happens, download GitHub Desktop and try again.
Launching GitHub Desktop
If nothing happens, download GitHub Desktop and try again.
Launching Xcode
If nothing happens, download Xcode and try again.
Launching Visual Studio Code
Your codespace will open once ready.
There was a problem preparing your codespace, please try again.
Latest commit
Git stats
Files
Failed to load latest commit information.
README.md
With the ever increasing dependance on wireless solutions, it sometimes is useful to know the devices around you. This software aims to help know the MAC addresses of the devices that are leaving any sort of trace on the airwaves.
This software is meant for educational purpose only. The author will not be held liable for any harm that is related to the software.
Instructions for Compilation
Compiling the sniffer follows the steps of standard CMake based build.
Basically, just run the following steps in the source directory:
mkdir bin cd bin cmake .. make
This will create a wifi-sniffer file which can then be used to sniff packets from an wireless interface.
Running ./wifi-sniffer without any parameters shows the usage
Usage: ./wifi-sniffer [options] interface -m, --macstat : Show number of detections of each MAC and timestamps -t, --time t : Run sniffer for t seconds (default: 60) -v, --verbose : Output more information -d, --debug : Show debugging information -h, --help : Show this help text Note: This program needs to be run as root
Do note that you need to have a wireless interface which supports «Monitor» mode to be able to use this software.
Please read the LICENSE file to know legal details of how you are allowed to use this software. But in short, this software is licensed under MIT License.
THE SOFTWARE IS PROVIDED «AS IS», WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
About
MAC Address sniffer. Captures packets on the WiFi network and outputs the MAC address and RSSI to STDOUT.
Сбор MAC-адресов мобильных устройств в маркетинговых целях
В нашу ИТ-компанию постоянно обращаются текущие и новые клиенты с целью реализовать какую-то идею. Задачу в большинстве случаев описывают простым языком, без даже примерного технического задания, но в итоге все трансформируется в полноценный технический проект, результатом которого становится реализация идеи клиента. Одна из таких задач звучала следующим образом: «Хотим чтобы реклама нашей продукции попадала в телефоны тех людей, которые проходят мимо наших магазинов». И далее трансформировалась в проект по созданию инструмента для сбора физических адресов мобильных устройств, которые находятся на определенной территории с дальнейшим использованием этой информации в маркетинговых целях.
Как это работает?
- На территории, которая интересует клиента, устанавливается оборудование сканирующее мобильные устройства по Wi-Fi, находящиеся в радиусе его действия.
- Физические адреса таких устройств (MAC-адреса) запоминаются и сохраняются в базу.
- База фильтруется — например, выбираются устройства, которые многократно были авторизованы в пределах периметра и отбрасываются те, которые появлялись единожды. Еще можно отфильтровать по производителям, например, возможно выделить все устройства компании Apple или другой.
- База загружается в инструмент интернет-маркетинга, такой как Яндекс.Аудитории или My target (соцсети Вконтакте, Одноклассники, МойМир) и из нее формируется целевая аудитория.
- После чего этой группе людей показываются рекламные баннеры, когда они пользуются соответствующей поисковой системой системой или социальной сетью.
Таким образом, на выходе получаем эффективную рекламную кампанию, так как рекламу видят только те лица, которые могут быть потенциальными покупателями.
Техническая реализация
Система состоит из трех компонентов:
Роутер Mikrotik в режиме фейк-точек доступа. Следующими командами активируем интерфейс, создаем на одном интерфейсе 3 беспроводные сети и присваиваем им SSID популярных публичных сетей (таких как Moscow_Wi-Fi_Free):
add disabled=no mac-address=00:00:00:00:00:F5 master-interface=wlan2 name=wlan4 ssid=Moscow_Wi-Fi_Free vlan-id=10 vlan-mode=use-tag add disabled=no mac-address=00:00:00:00:00:F8 master-interface=wlan2 name=wlan6 ssid=Subway vlan-id=10 vlan-mode=use-tag add disabled=no mac-address=00:00:00:00:00:FA master-interface=wlan2 name=wlan8 ssid=MT_Free vlan-id=10 vlan-mode=use-tag
/interface wireless sniffer set multiple-channels=yes streaming-enabled=yes streaming-server=192.168.40.77